The send port configuration corresponding to the message was not found

Home Page Forums BizTalk 2004 – BizTalk 2010 The send port configuration corresponding to the message was not found

Viewing 2 reply threads
  • Author
    Posts
    • #19753

      I developed a custom compression and decompression pipeline. but I stuck with a problem that it is not consistent.

      Some times My Service works fine and some times it suspend the service instance and says that

      A message going to a one-way send port is being suspended. Reason:The send port
      configuration corresponding to the message was not found.
      This usually happens when a send port was deleted while it still had some active messages.

      Then, I try to resume service instance (one or more times) ,It resumes successfully and my file is compressed.

      I read on the blog that there may some restriction on SSODB ,but if this is the case that It shouldn`t work even for  single time. http://www.sabratech.co.uk/blogs/yossidahan/2007/02/send-port-configuration-corresponding.html

      Any Idea why it is unconsistent?

       

      Thanks,

      Umair Ahmed.

       

    • #19754

      To confirm whether this issue is of my custom Pipeline Component or a configuration issue,

       I configure a send port with XMLTransmit Pipeline Component , which also exhibit same inconsistency

       

      Thanks,

      Umair Ahmed

    • #19826

      That very well could be an SSO issue.  Are you getting any SSO errors in the event log?  Intermittent SSO issues could cause the inconsistent results you are seeing.   Maybe try reproducing the error on another BizTalk install to see if it is something with your code or if it is related to the server where it is running.

      • #19870

          No, There is nothing related to SSO at eventlog.

        I checked SQL Server eventlog and I found following error

        Application eventlog entry:

        Event Type: Failure Audit
        Event Source: MSSQLSERVER
        User:  Domain\User
        Computer: SQLSERVER2005
        Description: Login failed for user ‘Domain\User’. [CLIENT: <local machine>]

        Security eventlog:

        Event Type: Failure Audit              Event Source: Security
        Event Category: Logon/Logoff        Event ID: 539
        User:  NT AUTHORITY\SYSTEM
        Computer: SQLSERVER2005       Description:
        Logon Failure:                              Reason:  Account locked out
        User Name:                                 Domain: 
        Logon Type: 3                              Logon Process: Authz   
        Authentication Package: Kerberos
        Workstation Name:                    Caller User Name: User
        Caller Domain: Domain

        To check if Account is actually locked I do log Off and Log in again and it allowed me to log in.I can connect the database via SQL Server Management studio using same Host Account.
        and, my point is that If the account is actually locked then Host should not process any Service instance. but if I try to resume the suspended service instance it works for me.

        These error are repeating but not consistent with my message suspension

        _______________________________________________________

        PS: I deployed the same solution on other BizTalk Server.Where it is running smoothly.

        any suggestion Please?

        Thanks

        Umair Ahmed

Viewing 2 reply threads
  • The forum ‘BizTalk 2004 – BizTalk 2010’ is closed to new topics and replies.