subscription error

Home Page Forums BizTalk 2004 – BizTalk 2010 subscription error

Viewing 1 reply thread
  • Author
    • #13375

      Hi. I’m new to the forum but not new to biztalk.

      The problem is this. I have an orchestration with 2 receive ports. 1 is a \”test\” and 1 is a \”live\”. They receive the same types of files so they should have the same pipeline.

      A batch of orders is receive through a zip file.
      A zip file has a summary file and a bunch of item files.

      I created a custom pipeline that would unzip the files and create new a new xml document for each order with all the necessary info. This worked great. No real problems except that I’d get a ton of orders at once and this would bog the biztalk production box down.

      The solution to this was to put a ripping program in front of the biztalk app that would do exactly as the pipeline would do. This works great as well and comes up with the same exact xml files as the pipeline.

      I took off the custom pipeline and replaced with the standard XmlReceive pipe. I’m getting subscription errors and I’m not sure why.

      Other notes: When viewing hat, the message type shows up on the context message but not on the actual messages message type. It is the correct message type. I’ve compared it with the one in the subscription viewer.

      Biztalk Admin errors:
      1. The Messaging engine failed to process a message submitted by adapter:FILE Source URL:C:\\BizTalkFiles\\NWM_Test\\*.xml. Details:Could not find a matching subscription for the message. . This error occurs if the subscribed orchestration schedule or send port has not been started, or if some of the message properties necessary for subscription evaluation have not been promoted. Please refer to Health and Activity Tracking tool for more detailed information on this failure.

      2.The \”FILE\” adapter is suspending a message coming from Source URL:\”C:\\BizTalkFiles\\NWM_Test\\*.xml\”. Details:\”Could not find a matching subscription for the message. \”.

      Hat stuff:
      Service class: \”Routing failure report\”

      What could this be?

      Thanks in advance

      • #13376

        It appears that I was reviewing the wrong things. I went back to look at my schemas to make sure that nothing on those had changed….

        I found that there were 2 settings marked as \”qualified\” when the default was \”unqualified\”. I changed those back to the default and it worked.

        They were \”Attribute formdefault\” and \”Element formdefault\”. Anyone know what these do?

    • #13374

      The attributeformdefault and elementformdefault attributes in a schema specify whether the elements/attributes and namespace qualified or not

      <schema targetnamespace=\”mynamespace\” elementformdefault=\”qualified\”>
      <element name=\”root\”>
      <element name=\”record\”/>

      would require Xml that looks like
      <ns0:root xmlns:ns0 =\”mynamespace\”>
      <root xmlns=\”mynamespace\”>
      i.e. all elements exists in \”mynamespace\”

      Using the default of unqualified
      <schema targetnamespace=\”mynamespace\” elementformdefault=\”unqualified\”>
      <element name=\”root\”>
      <element name=\”record\”/>

      would require Xml like this

      <ns0:root xmlns:ns0 =\”mynamespace\”>
      <root xmlns =\”mynamespace\”>
      <record xmlns=\”\”>
      Only the root node exists in \”mynamespace\” the record node has no namespace.

Viewing 1 reply thread
  • The forum ‘BizTalk 2004 – BizTalk 2010’ is closed to new topics and replies.