Root element is missing??

Home Page Forums BizTalk 2004 – BizTalk 2010 Root element is missing??

Viewing 2 reply threads
  • Author
    • #14252

      hi, i tried to use an oracle adapter in biztalk 2006, but i recieved this errors when i try to send a request. it complaints that root element is missing, anyone has ideas what could be wrong?? thanks


      A message sent to adapter \”OracleDB\” on send port \”SendToOracle\” with URI \”OracleDb://TIASOADB_104d10b2-9708-4fae-8884-6983ce398dc5\” is suspended.

      Error details: There was a failure executing the send pipeline: \”Microsoft.BizTalk.DefaultPipelines.XMLTransmit,
      Microsoft.BizTalk.DefaultPipelines.XMLTransmit, Microsoft.BizTalk.DefaultPipelines, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35\” Source: \”XML assembler\” Send Port: \”SendToOracle\” URI: \”OracleDb://TIASOADB_104d10b2-9708-4fae-8884-6983ce398dc5\” Reason: Root element is missing.

    • #14253

      hi it seems that the transformation of a message went wrong. i don’t know why it just mapping elements. do i need to initialize value for those mapped elements?

      however it works now, when i use the same schema that adapter created without any transformation.

      • #14254

        The message has not reached the Oracle Adapter yet.
        The error from the XmlAssembler in the send pipeline indictaes the message is empty.

        You need to look to where the message has come from, is there a map somewhere that is producing no output?

    • #25371

      source schema of the map may be not deployed properly.Try to redeploy the input schemas and check…..i hope it works…

Viewing 2 reply threads
  • The forum ‘BizTalk 2004 – BizTalk 2010’ is closed to new topics and replies.