Problems with Database Lookup

Home Page Forums BizTalk 2004 – BizTalk 2010 Problems with Database Lookup

Viewing 1 reply thread
  • Author
    • #12957

      I have an other problem too.

      I have a text file, which I would like to convert to xml. I also use a map with Database lookup to retrieve some data from a SQL Server database.
      When I test the map it works properly, but when I run the orchestration, in the xml file some elements become empty. These are the elements where I’d like to write the data from Value extractor (from Database lookup). Under every parent element the count of these child elements are correct but they are empty.
      The rest elements are filled properly. I doesn’t have any error or warning messages.
      Why it only works with the Test map function?

    • #12958

      I still can’t fix the problem.

      Can it be, that the receive pipeline with flat file disassembler makes the error? When I test the map, BizTalk don’t uses any pipeline. But when I run the orchestration, I must set a Pipeline, because without it, the orchestration can’t receive the text message.

      If there were any problems with database connection, then the map test should not be succeed. But it works. What are the differences between map testing and the map using in a running orchestration?

      • #12959

        Finally, I know what was the problem.

        I forgot to give the right permissions to the table (in the SQL Server).

        So the BizTalk Mapper’s Test Map function doesn’t watch the permissions, but the running Orchestration does. Strange, but true.

        • #12960

          I know it, and I use the Event viewer, but this special case, there are no error messages about permissions.
          In fact, the Biztalk orchestration works, if the were no errors. It makes the xml, and stores in the file, but without the data from the data table.

          Well, now it works, so I simply must watch the permissions in the future.

          • #12961

            I have seen tests working inside VS and not through BizTalk as well.

            I think it’s because the pipelines do things like remove empty nodes, allow early termination, etc. I think it’s basically all the “Additional Schema Properties” of flat files.

            Make sure I have it right, you need the empty nodes to show up? Or not be empty? One way would be to change the default value of the node. Example: if you have a node with “0000” and the default value is “0” I think the flat file disassembler will remove the node.

            Also, you might want to look at the suppress empty node property.

            Hope this helps.

            Stephen W. Thomas

            • #12962


              I bet when you run through VS your are running under your user id. Then, running though BizTalk you’ll be running under the host account.

              Good to know.

              • #12963


                I am not sure if you know this already but the EventLog in control panel is usually the place where you would get the error message. Mostlike the permission error was posted to there.


Viewing 1 reply thread
  • The forum ‘BizTalk 2004 – BizTalk 2010’ is closed to new topics and replies.