Oracle Adapter

Viewing 1 reply thread
  • Author
    • #12211


      I’ve installed BizTalk utilities, and the Oracle client because I would like to create an Oracle adapter!
      It was an error, I’ve installed Oracle 10g Data provider for .Net including ODAC, it contains:

      a) Oracle Data Provider for .NET (
      b) Oracle ODBC Driver (
      c) Oracle Provider for OLE DB (
      d) Oracle Objects for OLE (
      e) Oracle Services for Microsoft Transaction Server (
      f) Oracle Client (
      g) Oracle Universal Installer (

      But there is always the same error:
      Test connection failed because of an error in initializing provider. Oracle client and networking components were not found. These components are supplied by Oracle Corporation and are part of the Oracle Version 7.3.3 or later client software installation.
      Provider is unable to funcion until these components are installed

      Could you help me PLEASE ??? I need your help!

      Thank you in advance
      A. C.

    • #12212


      It should be compateble, because I installed BizTalk Utilities, which contains an Oracle Adapter, but It’s said that we should install an Oracle client!

      That’s what I’ve done, but there is always the same error message 🙁

      The responsible of bizTalk Utilities who sent me the license file sais that I had to install the version 10….

      I sent him an e-mail, and he replied:
      \”I’m assuming that you did set up the TNS for the Oracle Data Source etc.
      I think you’re facing a permissions problem here. Give everyone access to the Oracle folder including its subfolders\”

      I tried to check it but nothing 🙁

      what am I doing wrong ?!? :-((

      • #12213


        I have another question:

        shouldn’t I set the library loading path to point to the directory where I unzipped and installed the oracle client ????

        what do you think??

        • #12214


          I made a mistake, because I forgot to install Oracle Services for Microsoft Transaction Server.

          Now I don’t have this error message any more, but I have a new one 🙁

          Test connection failed because of an error in initializing provider. ORA-12514:TNS:listener does not currently know of service requested in connect descriptor

          do you know where I have to go for initializing the provider??

          Thank you in advance!

          • #12215

            yes, you are right, the problem comes from tnsnames.ora, because it doewn’t find any datasource!

            So you should create a data source from the Oracle Net manager and configure in Microsoft ODBC Administrator !!

            Then the connection is ok

            kind regards


            • #12216

              Is the Oracle Adapter you are trying to use compatible with Oracle 10g?

              I know the Microsoft Adapter for Biztalk 2006 (a.k.a. iway adapter) is but there are a lot of other Oracle Adapters out there.

              You might be better off contacting the vendor.

              • #12217

                About the only think I know about Oracle is to got to \\Network\\Admin and update the tnsnames.ora file.

                Best of luck.

Viewing 1 reply thread
  • The forum ‘BizTalk 2004 – BizTalk 2010’ is closed to new topics and replies.