I ran into an issue with bm.exe this morning.

Here’s the error I saw when running the bm.exe depoy-all command on a spreadsheet.

Deploying View… ERROR: The BAM deployment failed.

Encountered error while executing command on SQL Server “MyMachineName”.

String or binary data would be truncated.

The statement has been terminated.

I ran SQL Profiler the next time I executed this (as well as adding the -Trace:On parameter to the deploy-all command which _never_ seems to add any additional information. After a little bit of sleuthing it looked like this was the last statement executed before profiler showed sql statements that were deleting BAM tables, sprocs, etc.

— Register activity in RTA metadata table

INSERT [dbo].[bam_Metadata_RealTimeAggregations]












3600, — RTA window defaults to 60 hours

60, — Time slice defaults to 60 mins


The ConnectionString column’s max size is 3600 and you guessed it, my [HugeStringHere] value was larger than that. The string was actually not just a connection string and included CREATE CUBE and other statements in it.

It turns out that the PivotTable that I created in Excel for this particular view was too big – as in it had too much stuff in it (Dimensions, Measures). I created a smaller pivot table with fewer Dimensions in it and then the activity deployed without problems.