Hi all

I just had the funniest (NOT) experience (AGAIN) with the new BizTalk 2009 project

Somehow I had gotten into a situation, where I could add all the usual artifacts to
a BizTalk project except schemas. I could add orchestrations, send pipelines, receive
pipelines, maps, flat file schemas, property schemas, and flat file wizard schemas.
So the only thing I couldn’t add was “normal” schemas.

I thought: Who cares? I can just add either a property schema or a flat file schema
instead and then change the necessary properties on it to make it a normal schema,
and that worked for me for some time.

Then, I was contacted by Microsoft to test out a new QFE package that they have created
to fix an issue I have reported. The QFE package wouldn’t install, so i thought it
might have something to do with my project system being broken, so I chose to repair
my BizTalk installation.

The result was, that now I can add “normal” schemas, but I can’t add orchestrations
and property schemas. Also, naturally, the QFE package still doesn’t install 🙁 So
I ended up unconfiguring, uninstalling, reinstalling and reconfiguring. Everything
seems normal now. But for how long?

I really hope they have improved the project system for BizTalk 2010.