HTTP status 401: Unauthorized

Home Page Forums BizTalk 2004 – BizTalk 2010 HTTP status 401: Unauthorized

Viewing 2 reply threads
  • Author
    • #13896

      Hi ,
      I am running a BTS2004 project which is consuming a webservice made on the IIS running on same machine.

      In the Evnt viewer, it gives me the follong error

      Details:\”The request failed with HTTP status 401: Unauthorized.\”
      This example is from the ‘BizTalk 2004 Unleashed’ book.

      I know it has somthing to do with the security setting in the web service.

      But what changes can be made to make it work?


    • #13897

      The HTTP 401 error is at the IIS level.
      Check in IIS for the directory security on the Web Service virtual directory. The easiest fix is to allow anonymous.
      Otherwise set the Biztalk send port to have matching security Basic or NTLM with appropriate credentials.

      • #16095

        Hi Greg,


        I have now solved the problem I had with the 405 error, but this is now the error I get: error: The remote server returned an error: (401) Unauthorized.

        I searched it up and the suggestion is to go into the biztalk admin console and changes the security settings under the send port's properties box. The problem I have now is that when I right click on the send port there is no properties tab listed. How do I change the send ports security setting to NTLM?



        • #20512

           Hi Sharon,

          May I know how did you solve the 405 error?  Thanks


          • #20513

            I’m just guessing, but I bet the SOAP adapter uses NTLM by default, and that it will use the account that the host instance is running under.  Does that account have access to the web service?

    • #55483

        Booky Wook 2: This Time it’s Personal — Russell Brand — 9780007328352

    Viewing 2 reply threads
    • The forum ‘BizTalk 2004 – BizTalk 2010’ is closed to new topics and replies.