I have Visual Studio 2005 with Service Pack 1 installed and I cannot debug any web service or web application. This worked for a while and then it stopped working. I researched this on a couple of sites and the suggested solutions were

– Debug with F5
– Run with CTRL + F5 
– copy WebDev.WebServer.exe from another machine if not present in .Net Framework folder
– From .Net Framework folder run WebDev.WebServer.exe /PORT:8081 /PATH:”path to web app
– disable or open firewall port

I tried all of these and it still failed with several errors
Configuration system failed to initialize
Unable to launch Visual Studio’s Localhost Web Server.
 ASP.NET Development Server failed to start listening on port 8081.
 Error message:
 Configuration system failed to initialize

In my case, this error was caused by system.net\machineKey element in machine.config. Removing this element fixed the problem. Of course on a production system you don’t want to this but you would not run WebDev.WebServer.exe either so that’s not actually a problem.
I hope this helps other people facing the same problem!