Hi all

The other day a developer who needs to call a BizTalk exposed web service approached
me and told me that there was an error in the wsdl – something about the Response
having the wrong fields.

So, I fixed it – I changed the XSD and ran the WCF Service Publishing Wizard again.

I called the developer and told him that everything was fine now. He refreshed his
service reference and told me that everything was just as it was before. So I thought;
Restart IIS.. and I did. Developer goes: Jan, what is wrong with you? Everything is
still the same!

So now I actually need to start thinking

Turns out, that silly I just did this:

  1. Made my changes to the XSD
  2. Recompiled
  3. Run the Wizard
    1. Point to the newly compiled assembly
    2. Finish the wizard


    BUT, what I forgot was to deploy the newly created assembly or at least GAC it. Because
    the wizard, even though you point to a .DLL in the file system, will look for the
    assembly in the GAC with the same strong name and used that instead of the .DLL you
    chose. To me this is really silly It could at least provide a warning that it will
    ignore the assembly I chose before ignoring it.

    Anyway, after deploying the new assembly, everything worked just fine.