Recently while I was working on a map I constantly used to get this error

Error 3 Output validation error: Root element is missing

I thought that since I have not mapped few Destination fields it might be throwing such error.

I tried setting Output Validation False for the Map.

Still I was getting the same error.

The Map was a simple one to one link map.

I was confident that my input xml file was perfect and  I did confirm it by Validating it against the Input Schema again.

It got succeeded.No errors at all.

Now where could be the problem be.

So I just googled and got this link by Stephen.

And then I cross verified my Target namespace in the input Schema with the input xml file.

There was a blank space before and after the namespace in my Schema which was creating this problem for me.

Moral of the story:

” Validating the xml file against the Schema never assures that the two match each other”.



NISHIL is online…Click to Chat right now!


    Join BiztalkMumbai    
 MSN Groups