I ran into an issue working with the AWESOME MUrl sample trying to reach Twitter from inside Intellipad (running in “MUrl mode”). I’m doing this post for the benefit of others that may run also into this, there are actually two solutions

If you haven’t seen MUrl in action, please see my previous post about it and do check it out. Bottom line is that the sample is a DSL (written in “M” of course) for doing REST client requests, and “MUrl mode” lets you do those requests right from inside Intellipad. Super cool

Where I ran into an issue was that although I was able to query Twitter no problem with MUrl from Intellipad, when I tried posting I would get an “Expectation Failed” error message. I was somewhat amused that somehow it seemed that I was not living up to some service’s expectations 🙂 but mostly I was annoyed that I could not do this. After a bit of looking around, I found this post that explained what was going on.

I made the code change to the MUrlRuntime.cs file as shown below:

Alternatively, you could make the equivalent change by adding this to the ipad.exe.config:



<servicePointManager expect100Continue=”false” />



Technorati Tags: Oslo,M,MUrl,DSL

(for the benefit of people using search engines, other text in the error message was “Expect: 100-continue”, and some text from Twitter saying “we only allow the 100-continue expectation”)