Home Page › Forums › BizTalk 2004 – BizTalk 2010 › why my recieve location is getting disabled when iam refreshing .
- This topic has 2 replies, 1 voice, and was last updated 9 years, 8 months ago by
community-content.
-
AuthorPosts
-
-
April 22, 2008 at 12:00 AM #19417
Hi while im refreshing the application my recieve loaction is getting disabled…
Here is the error im getting :
The receive location “netMsmq” with URL “net.msmq://HEDWBA07/Private/OpsFramework3”
is shutting down. Details:”The Messaging Engine failed while notifying an adapter of its configuration. “.
Cpuld you please help me in truble shooting this !
-
April 22, 2008 at 1:51 AM #19421
I’ve seen this issue before with permission problems on the standard FILE adapter – when the user polling the directory for files doesn’t have the necessary permissions on that directory, the receive location shuts itself down.
I’ve done a quick check with the WCF net-MSMQ adapter that you are using and have managed to re-create the problem, receiving the error:
The receive location “Receive SuspOrchWsStub Location” with URL “net.msmq://localhost/private/biztalk.test.queue” is shutting down.
Details:” The Messaging Engine failed while notifying an adapter of its configuration. “.
However, the cause of the error is contained in the preceeding error (in the Event Log):The Messaging Engine failed to add a receive location “Receive SuspOrchWsStub Location” with URL “net.msmq://localhost/private/biztalk.test.queue” to the adapter WCF-NetMsmq”. Reason: “System.InvalidOperationException: Binding validation failed because the binding’s MsmqAuthenticationMode property is set to WindowsDomain but MSMQ is installed with Active Directory integration disabled. The channel factory or service host cannot be opened.
Can you check whether you have another error which details the cause of the Receive Location shutdown? This should help you diagnose the cause of your problem.
Regards, Nick.
-
April 22, 2008 at 7:01 AM #19425
I’ve had this problem as well and it was related to permissions.
On a side note, even when I had the correct credentials coded into the receive location I was still getting the error…we forgot the allow the account to “Log Into…” the machine that the share was located on. Once this was set, everything worked fine. I’m not sure if it was related to the BizTalk service running as a local account or not.
-
-
AuthorPosts
- The forum ‘BizTalk 2004 – BizTalk 2010’ is closed to new topics and replies.