Published By: Bill Chesnut

I have just finished a series of BizTalk 2013 Environment Installs and was testing one of my new development environments and deploy the HelloWorld SDK Sample (issues with the samples will be covered in another blog post) and dropped a couple of sample message in and then opened the BizTalk 2013 Admin Console, clicked on the Group Hub and then click Completed instances and to my surprise nothing.  I proceeded to go through my normal checks, application started, hosts started and looking in the output folder, the output message was there but still not tracking.  I then looked at the ports and turned tracking on, but that should not be necessary, submitted a couple more message and still nothing in the Completed instances.

I then looked at the default pipelines to make sure tracking was turned on

image

I opened the PassThruReceive and the tracking was on

image

I then opened the XMLReceive and No Tracked Events were enable, found the cause of my missing Completed instances

image

I enabled the tracking on the PassThruTransmit, XMLReceive and XMLTransmit. I think submitted some more messages, I now have the Tracked events for the pipelines, still missing the ones from Orchestration, not sure whether this is a binding issue with HelloWorld SDK sample of a new default.

image

I opened the Tracking page on the HelloWorld Orchestration and it was turned off also, turned on Track Events and now I have what I was expecting.

image

Hope this helped you figure out your issues with BizTalk 2013 Tracking.


More ...