Integrating Integrators – BizTalk, Windows Azure, Windows Workflow, and Beyond

how to change encoding in Schema for Special Character?

BizTalk 2006

This group is for all content related to BizTalk Server 2006. This includes a forum, samples, videos, labs, and tools. Most of the content here also applies to other versions of BizTalk beyond 2006.

how to change encoding in Schema for Special Character?

  • rated by 0 users
  • This post has 4 Replies |
  • 1 Follower
  • Hello,

    I have a xml source file and will pass through Biztalk and transformed to flat file.

    In my source xml file, some special character will be included, (e.g. úóíá) and the file failed schema validation, here's the error:

    An error occurred when parsing the incoming document: \"Invalid character in the given encoding.\"

    The source file doesn't have XML declaration included. And the schema i created in BTS 2006 has the default:
    <?xml version=\"1.0\" encoding=\"utf-16\" ?>

    To solve this problem i want to change the schema encoding to
    <?xml version=\"1.0\" encoding=\"iso-8859-1\" ?>

    But i didn't find any attribute in XML Schema for source file to change the setting that like what we got in Flat File schema, change \"Code Page\" to set to other encoding, though i didn't find iso-8859-1 there.

    If i changed the encoding for source file, do i need to change it for transformed schema (in this case, flat file schema) as well?

    Can anybody shed some light on this?

    Many Thanks.

    Merry
    Edit
  • Solved this problem by using a custom pipeline:

    http://www.winterdom.com/weblog/2006/01/31/FixMessageEncodingCustomPipelineComponentSample.aspx

    in the pipeline, choose to use encoding \"Western European\", or called Latin-1 (iso-8859-1).

    It covers most West European languages, such as French (fr), Spanish (es), Catalan (ca), Basque (eu), Portuguese (pt), Italian (it), Albanian (sq), Rhaeto-Romanic (rm), Dutch (nl), German (de), Danish (da), Swedish (sv), Norwegian (no), Finnish (fi), Faroese (fo), Icelandic (is), Irish (ga), Scottish (gd), and English (en).
    Edit
  • Anonymous:
    Hello,

    I have a xml source file and will pass through Biztalk and transformed to flat file.

    In my source xml file, some special character will be included, (e.g. úóíá) and the file failed schema validation, here's the error:

    An error occurred when parsing the incoming document: \"Invalid character in the given encoding.\"

    The source file doesn't have XML declaration included. And the schema i created in BTS 2006 has the default:
    <?xml version=\"1.0\" encoding=\"utf-16\" ?>

    To solve this problem i want to change the schema encoding to
    <?xml version=\"1.0\" encoding=\"iso-8859-1\" ?>

    But i didn't find any attribute in XML Schema for source file to change the setting that like what we got in Flat File schema, change \"Code Page\" to set to other encoding, though i didn't find iso-8859-1 there.

    If i changed the encoding for source file, do i need to change it for transformed schema (in this case, flat file schema) as well?

    Can anybody shed some light on this?

    Many Thanks.

    Merry
    Edit
  • I have the same problem

    Edit
  • hi, can somebody help? i have problems with czech diakritic

    thanks

Page 1 of 1 (5 items)