Integrating Integrators – BizTalk, Windows Azure, Windows Workflow, and Beyond

Document specification failed to load error

BizTalk 2006

This group is for all content related to BizTalk Server 2006. This includes a forum, samples, videos, labs, and tools. Most of the content here also applies to other versions of BizTalk beyond 2006.

Document specification failed to load error

  • rated by 0 users
  • This post has 5 Replies |
  • 0 Followers
  • Hi,
    I am following the BizTalk Server 2006 tutorials by Microsoft. When I use a receive shape to receive a one-way message from a Web service, I get the following error:

    Event Type: Error
    Event Source: BizTalk Server 2006

    Description:
    There was a failure executing the receive pipeline:
    \"Microsoft.BizTalk.DefaultPipelines.XMLReceive, Microsoft.BizTalk.DefaultPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35\"
    Source: \"XML disassembler\"
    Receive Port: \"ASN_ReceivePort\" URI: \"/b2borchestrations_webservice/B2BOrchestrations_B2BProcess_ReceiveASN_Port.asmx\"
    Reason: The document specification <B2BSchemas.AdvancedShipNotice> from assembly <B2BSchemas, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f5f7841d15c6dc86> failed to load. Verify the schema for this document specification is deployed and is in the Global Assembly Cache.

    This receive port is a port of the orchestration exposed as a Web service. I tried to undeploy ( including removing the assemlies manually from GAC ) and redeploy the solution ( following the tutorial exactly or adjusting it ) three times. But simply cannot get rid of this problem. Your help is greatly appreciated. I am new to BizTalk. Thanks.

    David
  • You can quickly check whether a schema is deployed or not.

    There is a file C:\\Program Files\\Microsoft BizTalk Server 2006\\Developer Tools\\BtsAsmExt.dll that enables you to browse the deploy Biztalk asssemblies

    [code:1:89eca9a1b0]cd C:\\Program Files\\Microsoft BizTalk Server 2006\\Developer Tools
    regsvr32 btsasmext.dll
    Close Windows Explorer
    Open Windows Explorer[/code:1:89eca9a1b0]

    Under My Computer you should have a Biztalk Server Assemblies node.

    If you don't have the SDK installed you can copy just this file to the Biztalk Server.

    The schema type is defined using the target namespace and root node.
    You need to check the incoming suspended message and make sure the target namespace and root node match your expected schema.
    e.g.
    <root xmlns=\"targetnamespace\">
    or
    <ns0:root xmlns:ns0=\"targetnamespace\">

    Another gotcha - if you redeploy an assembly you need to restart the Biztalk Host Instance. In this case the Biztalk Isolated Host Instance which is IIS - just use the iisreset command.
  • Thank you. Restarting BizTalk Host Instance resolved my issues. Appreciate the help provided here.

    Edit
  • Hi,

    Stumbled upon the same problem but I'm using BizTalk 2010. I managed to solve the issue by referring to this article: www.mpspartners.com/.../BizTalk2010andAssemblyCache

    My webservice application pool must use the same .NET Framework version with BizTalk, in this case v4. If not, both are not looking into the same version of assembly cache. Just to share if anyone else stumbled upon the same error.

    rgds,

    sazul

    Edit
  • Thanks Suzal.. I changed .Net version for my application pool and it started working for me as well..

    -Abhijeet

    Edit
  • Restarting host instances worked for me too! :D Thanks :)

    Edit
Page 1 of 1 (6 items)